Flotr2をbowerでインストールしてつかう

これでインストールはできますが。bowerモジュールとして適切に実装されていないのか、beanと_(underscore)という2つの依存オブジェクトがグローバル名前空間に存在することを前提としているようで、次のようなエラーがでたり、

それを解決すると今度は、requireの戻り値が何故かunderscoreオブジェクトだったりします。Flotr2はグローバル変数Flotrを定義するだけで、module.exportsに適切な何かをセットするような作りになっていないようです。

そこで、こんなファイルを作ります。underscoreとbeanは事前にbowerでインストールしておきます。

こうしておけば、次のような感じで使うことができます。

さんぷる。
https://github.com/fxfan/flotr2_samples

シェアする

  • このエントリーをはてなブックマークに追加

フォローする